Results 1 to 7 of 7

Thread: Mbe ecu

  1. #1
    Join Date
    Jul 2011
    Location
    Toronto, Canada
    Posts
    140

    Default Mbe ecu

    Anybody running a MBE ignition only ECU?

  2. #2
    Join Date
    Jul 2010
    Location
    Mahwah, NJ
    Posts
    877

    Default

    Check out SBD Motorsport

    They helped me get my Cosworth programed over the phone!

    Karl
    2010 Caterham Superlight R
    Cosworth 2.3L-309HP, Sadev Sequential Gearbox, Geartronics Paddle Shift

  3. #3
    Join Date
    Jul 2011
    Location
    Toronto, Canada
    Posts
    140

    Default

    I have a Westfield with a 2l Vauxhaul and a MBE ECU. Just wondering if anybody has had any issues with them. Once in a while my car wont start. It cranks but no go. I traced it to the 12 volts that goes to the centre wire on the coil pack. The voltage stops when I try to start it. If I jump 12 volts to it directly from the battery it starts and is good for days again.

    Also when driving, sometimes I hear what sounds like a loud wheezing sound coming from I think the ECU that is mounted under the dash on the passenger side.

    Ron.

  4. #4
    Join Date
    Mar 2011
    Location
    Melbourne, Floirda
    Posts
    572

    Default

    I see you are using an ignition only control ECU and you are apparently losing the 12 power source to the coil pack. I'm not sure but I believe the ignition switch circuit powers up the coil pack vs. the ECU. The ECU triggers the coil pack. Look over your wiring schematic to see if that is the case.

    Years ago on another car, I had starting issues. On the "run" position, power was supplied to the ignition but on the "start" position, the power dropped off. If I quickly let go of the "start" position and drop into the "run" position, the car would start and run. Otherwise, I could crank until the battery died. Good luck.
    2004 Caterham R300
    2007 C6Z06 Vette
    2007 Z51 Vette ragtop
    1969 Corvette Big Block
    1967 Pontiac GTO
    1965 Corvair Corsa 140 HP
    1966 Corvair Corsa Turbo
    1987 Porsche 930 Turbo
    2004 Porsche 996TT cabriolet
    all still in the garage

  5. #5
    Join Date
    Mar 2011
    Location
    Melbourne, Floirda
    Posts
    572

    Default

    I just got through checking the wiring schematic of Megasquirt and Pectel and it would appear I am wrong about my assumption on the 12 volt power source. On one, power goes to a relay which feeds the ECU which then distributes to needs. Sounds like it may be a bad connection......hard to find until it goes bad completely.
    2004 Caterham R300
    2007 C6Z06 Vette
    2007 Z51 Vette ragtop
    1969 Corvette Big Block
    1967 Pontiac GTO
    1965 Corvair Corsa 140 HP
    1966 Corvair Corsa Turbo
    1987 Porsche 930 Turbo
    2004 Porsche 996TT cabriolet
    all still in the garage

  6. #6
    Join Date
    Jul 2011
    Location
    Toronto, Canada
    Posts
    140

    Default

    Thank you for the response. I know I should trace all the wires and clean all the contacts. Having too much fun driving it though!!!!

    Had my girlfriend in the car today and she seems to think the sound is coming from the rear of the car and not from under the dash. Up on the lift it goes for an inspection.

  7. #7
    Join Date
    Jun 2011
    Location
    Crete
    Posts
    140

    Default

    MBE here,but no issues.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •