Results 1 to 2 of 2

Thread: LED's

  1. #1
    Join Date
    Apr 2018
    Location
    Ft Lauderdale
    Posts
    209

    Default LED's

    I have LEDs for my rear running/brake and turn signals)
    I have a ballast resistors wired into the flasher circuits (to stop hyper Flash) do I need one for the rear lights?
    As I seem to be having some issues, the turn signal buzzer is sounding, not full but like it is being fed a weak voltage and both the turn signal and high beam indicator lights are on, dim but on.
    The left turn signal is not working with the headlights on but the right seems to be flashing.

    If I switch off the headlights everything seems OK lights go out buzzer stops this happened at the end of a 45 minute drive this evening.
    Last edited by Brightonuk; 10-17-2020 at 08:17 PM.
    Life Can Be Cruel

  2. #2
    Join Date
    Jul 2009
    Location
    Arkansas and . . .
    Posts
    3,699

    Default

    I have LED turn (front and rear) tail and brake lights. Im running the Painless Wiring 80230 LED flasher with no issues: https://www.painlessperformance.com/wc/lv.php?sl=80230

    Install instructions: https://www.painlessperformance.com/Manuals/80230.pdf
    Stalker V8, chassis #85

    Stalker Chassis #85 Build Gallery
    Stalker Chassis #85 Owner Thread

    Get up in the morning and give the day your very best. You donít get it back.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •