Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: OBD2 port on 2003 Birkin ???

  1. #1
    Join Date
    Aug 2020
    Posts
    9

    Default OBD2 port on 2003 Birkin ???

    Not only did I not find an obd port but it looks like I have an aftermarket ECU. Anyone familiar with Birkins who can point me in the right direction.
    The problem I am having is I'm not getting any power to the injectors. Was hoping the OBD2 codes would have given me an idea where to start troubleshooting.

    Gary

  2. #2
    Join Date
    Aug 2011
    Location
    Greenville, SC
    Posts
    426

    Default

    Quote Originally Posted by RiverRat View Post
    Not only did I not find an obd port but it looks like I have an aftermarket ECU. Anyone familiar with Birkins who can point me in the right direction.
    The problem I am having is I'm not getting any power to the injectors. Was hoping the OBD2 codes would have given me an idea where to start troubleshooting.

    Gary
    Going to need a little more information on what you have.
    Several aftermarket ECU's out there, none of them have OBD2 ports.
    What ECU do you have? (name should be on the ECU itself)
    Which injection system do you have?
    The next question is a bit simpler, have you pulled and checked all of the fuses and relays?

    Bill

  3. #3
    Join Date
    Aug 2020
    Posts
    9

    Default

    I have Jenvey injectors . I have checked all the fuses in the fuse block. I have not checked the relays.

    The bracket for the ECU is almost as big as the unit itself. I cannot see any writing on it. I will have to pull the bracket off it to find anything.under the dash is kind of a tight fit for me.

    Gary

  4. #4
    Join Date
    Aug 2020
    Posts
    9

    Default

    Name:  IMG_20200816_162153869.jpg
Views: 83
Size:  30.5 KB

    Here is a photo of the ECU. As you can see most of it is covered up.

  5. #5
    Join Date
    Feb 2009
    Location
    The Frozen Northeast
    Posts
    561

    Default

    What is the provenance of your car? Do you know who built it?

  6. #6
    Join Date
    Aug 2020
    Posts
    9

    Default

    Not a clue. Bought it used.

  7. #7
    Join Date
    Aug 2011
    Location
    Greenville, SC
    Posts
    426

    Default

    Quote Originally Posted by RiverRat View Post
    Not a clue. Bought it used.
    Where did you but it out of (state)?
    Color combination?
    Pictures?
    Sounds strange, but when may know the cars origins, or maybe even recognize it as one where the owner used to be here.

    Bill S.

  8. #8
    Join Date
    Aug 2020
    Posts
    9

    Default

    Name:  attachment-4.jpg
Views: 85
Size:  20.2 KB
    P
    I bought it from a member on here but it was probably 7 ?? years ago.

  9. #9
    Join Date
    Feb 2009
    Location
    The Frozen Northeast
    Posts
    561

    Default

    Picture of engine bay, front end & rear?
    Looks like the old style nose and side mirrors that tmw used for a while.Any idea of original registration/ build year? Could be a TMW zetec build? Try reaching out to Dick. He may have built it and know what type of ECU you have.

  10. #10
    Join Date
    Aug 2020
    Posts
    9

    Default

    MRMustang,

    I believe this was your old car.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •