Page 8 of 8 FirstFirst ... 678
Results 71 to 80 of 80

Thread: New guy. Here is my Cat

  1. #71
    Join Date
    May 2018
    Location
    Albany, NY
    Posts
    350

    Default

    Quote Originally Posted by Croc View Post
    Oh dude! I can so relate to that photo of steaming engine and the fluro green coolant leaking out. Happened a few times on my Caterhams and more recently, in the Fiat. Always on an isolated country road with no phone signal.

    I recommend carrying some silicone tape in the tool kit for hose bursts. Would not have solved your problem this time but that stuff has saved me with many a coolant pipe burst.
    Good idea. I'll do that.

    I got cocky and pulled the tools out that I had in the back for the last month or so. Didn't want to keep risking them moving/banging around the back while I'm waiting on the new tool box/bag being made by SBFS. I even carried spare water for a while.
    2001 Caterham Superlight R

  2. #72
    Join Date
    Oct 2006
    Location
    Cincinnati
    Posts
    3,746

    Default

    Croc: So what is this Fiat you have been referencing of late?
    Kitcat:AKA, Sir Spinsalot
    '97 Caterham Super Sprint, 1700 Crossflow-sold
    '09 Birkin S3, Duratec-sold
    '03 Caterham Zetec track car
    '19 Honda Type R, sold
    '19 Miata Clubsport

  3. #73
    Join Date
    May 2018
    Location
    Albany, NY
    Posts
    350

    Default

    New toys arrival today



    Sent from my Pixel 3a XL using Tapatalk
    2001 Caterham Superlight R

  4. #74
    Join Date
    May 2018
    Location
    Albany, NY
    Posts
    350

    Default

    Also got a tool to see how well my ITBs are balanced.

    Most are similar. One is a but high @ ~9 vs rest @ ~7.5

    Not sure if its something to be concerned about









    Sent from my Pixel 3a XL using Tapatalk
    Last edited by Vovchandr; 07-21-2020 at 08:13 AM.
    2001 Caterham Superlight R

  5. #75
    Join Date
    May 2018
    Location
    Albany, NY
    Posts
    350

    Default

    Other issues.

    Mount was fixed once already and failed again. Don't think I can fix again, will order a new one.

    I saw one company make a carbon fiber guard but they haven't been getting back to me. Likely a one off







    Sent from my Pixel 3a XL using Tapatalk
    2001 Caterham Superlight R

  6. #76
    Join Date
    May 2018
    Location
    Albany, NY
    Posts
    350

    Default

    Team red stripes

    In other news I now appear to be getting about 30 to 35 mpg. Doesn't feel right .. at all. Feels more wrong than 9mpg from before.



    Sent from my Pixel 3a XL using Tapatalk
    2001 Caterham Superlight R

  7. #77
    Join Date
    Jan 2020
    Posts
    158

    Default

    Quote Originally Posted by Vovchandr View Post
    New toys arrival today



    Sent from my Pixel 3a XL using Tapatalk
    I'm intrigued, what's what in the picture?
    Greg

  8. #78
    Join Date
    May 2018
    Location
    Albany, NY
    Posts
    350

    Default

    All is from Soft Bits for Sevens

    Top left - tool box
    Rest of left - trunk padding. As Croc mentioned in other thread and I know from personal dent experience, things in the trunk get in motion and want to stay in motion until soft aluminum panel tries to stop it.

    Top right - heavy duty zip tonneau
    Middle right - light duty tonneau
    Bottom right - light duty rain cover
    2001 Caterham Superlight R

  9. #79
    Join Date
    May 2010
    Location
    Laurel MD
    Posts
    188

    Default

    In the first balancing picture, what is the sensor in between the cams, looks like a temp sensor. Whatever it is it has a nice blob of goop on the top! I would order a new one it looks like the connector has failed and someone has done a temp bodge repair.

    Graham

  10. #80
    Join Date
    May 2018
    Location
    Albany, NY
    Posts
    350

    Default

    Quote Originally Posted by fastg View Post
    In the first balancing picture, what is the sensor in between the cams, looks like a temp sensor. Whatever it is it has a nice blob of goop on the top! I would order a new one it looks like the connector has failed and someone has done a temp bodge repair.

    Graham
    That should the VCT cam sensor for valve adjustments on Zetecs. From what I've been told mine is disabled on mine since the build of the car. I'm not even sure if Pectel ECU would have the ability to accommodate the VCT even if it wanted to.

    The blob of goop has been on there since I've owned the car and honestly it hasn't bothered me or ever has been on my mind.
    2001 Caterham Superlight R

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •