Tab Content
  • papak's Avatar
    04-01-2020, 02:09 AM
    papak replied to a thread T-9 issue in General Tech
    The shifter goes into position just fine. It just seems to lose all drive, as if it had popped out of gear. All other gears work fine. Pm on the way....
    2 replies | 160 view(s)
  • papak's Avatar
    03-29-2020, 10:54 PM
    papak replied to a thread 2.0L Duratec Rebuild in General Tech
    The adhesive wasn't obvious to me either at first but when I heated the surrounding surface, it oozed a little at the seam. I figured that if I got...
    77 replies | 5324 view(s)
  • papak's Avatar
    03-29-2020, 08:08 PM
    papak replied to a thread 2.0L Duratec Rebuild in General Tech
    The elbow in the top of the water pump housing was secured with an adhesive. On my installation, I needed to turn it about 30 degrees as I recall. I...
    77 replies | 5324 view(s)
  • papak's Avatar
    03-29-2020, 08:05 PM
    papak replied to a thread 2.0L Duratec Rebuild in General Tech
    The elbow in the top of the water pump housing was secured with an adhesive. On my installation, I needed to turn it about 30 degrees as I recall. I...
    77 replies | 5324 view(s)
  • papak's Avatar
    03-29-2020, 04:27 PM
    papak started a thread T-9 issue in General Tech
    Finally got out for a solo blat this morning through the Malibu canyons. On the way back home on the freeway. I lost all drive in fifth gear at 75...
    2 replies | 160 view(s)
  • papak's Avatar
    03-14-2020, 02:22 AM
    papak replied to a thread Duratec Starter in General Tech
    The only difference I have found is with the flywheel ring gear spacing. I am running a Ford Focus flywheel and the Panther starter wouldn’t engage...
    4 replies | 306 view(s)
No More Results
About papak

Basic Information

About papak
Location:
Los Angeles

Statistics


Total Posts
Total Posts
240
Posts Per Day
0.12
General Information
Last Activity
04-02-2020 01:34 AM
Join Date
12-06-2014
Referrals
0